Router con open-wrt como repetidor wifi


En ocasiones, nos podria interesar que nuestro router con   open-wrt   nos permitiera conectarnos a una red wifi para retransmitir esta señal  y de esta forma mejorar el alcance del router principal.

Para  configurar nuestro router con open-wrt   seguiremos estos pasos:

1º Configuraremos el  fichero  /etc/config/network
config interface loopback
option ifname   lo
option proto    static
option ipaddr   127.0.0.1
option netmask  255.0.0.0

config interface lan
option ifname   eth0
option type     bridge
option proto    static
option ipaddr   192.168.2.1   #es importante cambiar este valor para que nos podamos conectar al router anfitrion  cuya io sera 192.168.1.1
option netmask  255.255.255.0
option gateway  ‘192.168.1.1’

config interface wan
option ifname ath0
option proto    ‘dhcp’
option dns      ‘80.58.61.250’
option ipaddr   ”
option netmask  ”
option gateway  ‘192.168.1.1’

2º Configuraremos el fichero /etc/config/wireless

config wifi-device  wifi0
option type     atheros
option channel  5
option disabled ‘0’
option mode     ’11bg’
option diversity        ‘0’
option txantenna        ‘0’
option rxantenna        ‘0’
config wifi-iface
option device   wifi0
option network  lan
option mode     ap
option ssid     OpenWrt    #nueva red  a la que nos conectaremos
option encryption wep
option key      ‘1’
option hidden   ‘0’
option isolate  ‘0’
option txpower  ‘0’
option bgscan   ‘0’
option wds      ‘0’
option key1     ‘FFFFFFFFFFFFFFFFFFFFFFFFFF’   #clave wep en formato exadecimal

config wifi-iface
option device wifi0
option network wan
option mode sta
option ssid WLAN_7F  # red a repetir  que repetiremos
option encription wep
option key      ‘1’
option encryption       ‘wep’
option hidden   ‘0’
option isolate  ‘0’
option txpower  ‘0’
option bgscan   ‘0’
option wds      ‘0’
option key1     ‘FFFFFFFFFFFFFFFFFFFFFFFFFF’ #clave wep de la red a repetir

3 Revisamos la conexion en Luci en http:\\192.168.2.1

Primero miramos network

4-Y  ahora revisamos el apartado de wireless tanto generales como para la LAN y la WAN

Anuncios

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s