Como recompilar una aplicación en Android en otra version


Si esta  desarrollando un aplicación con Android Studio  , en el momento que se crea un proyecto nuevo habrá especificado el  API LEVEL de la  aplicación Android

Seguro que con bastante esfuerzo habrá desarrollado partir de la estructura inicial  su aplicación basándose en esa especificación ,pero una vez  finalizado el desarrollo  ( y las pruebas de la app) si  intenta subirla a Google Play,  quizás  en un segundo intento vez, habrá visto que da error en la subida del APK debido a que ya tiene un archivo con ese código de versión.

Este problema  también le puede ocurrir cuando desee probar su aplicación con otro terminal   que   cuente con una versión de Android inferior

En este post precisamente  vamos  a ver cómo cambiar el código de versión de una aplicación Android o el nivel del  API  para  solucionar  precisamente los problemas comentados  .Como vamos a ver es un procedimiento realmente sencillo, y no debería llevarnos ninguna complicación.

En primer lugar,  veamos  en la siguiente tabla las diferentes versiones del nivel de API de Android  en relación a la versión  que todos conocemos : la versión de la Plataforma

Versión de la plataforma Nivel de API VERSION_CODE
Android 7.0 24 N
Android 6.0 23 M
Android 5.1 22 LOLLIPOP_MR1
Android 5.0 21 LOLLIPOP
Android 4.4W 20 KITKAT_WATCH
Android 4.4 19 KITKAT
Android 4.3 18 JELLY_BEAN_MR2
Android 4.2 y 4.2.2 17 JELLY_BEAN_MR1
Android 4.1 y 4.1.1 16 JELLY_BEAN
Android 4.0.3 y 4.0.4 15 ICE_CREAM_SANDWICH_MR1
Android 4.0, 4.0.1 y 4.0.2 14 ICE_CREAM_SANDWICH
Android 3.2 13 HONEYCOMB_MR2
Android 3.1.x 12 HONEYCOMB_MR1
Android 3.0.x 11 HONEYCOMB
Android 2.3.4 10 GINGERBREAD_MR1
Android 2.3.3
Android 2.3.2 9 GINGERBREAD
Android 2.3.1
Android 2.3
Android 2.2.x 8 FROYO
Android 2.1.x 7 ECLAIR_MR1
Android 2.0.1 6 ECLAIR_0_1
Android 2.0 5 ECLAIR
Android 1.6 4 DONUT
Android 1.5 3 CUPCAKE
Android 1.1 2 BASE_1_1
Android 1.0 1 BASE
Si por la razón que sea  quiere cambiar el API Level, por ejemplo de API  16 ( correspondiente a : Android 4.1 Jelly Bean)  a API 22 ( correspondiente a : Android 5.1.0 (Lollipop)  sólo hay que seguir los siguientes pasos:
  •  Buscar la carpeta app del menú desplegable “Project” ( o la carpeta que contenga el nombre de nuestra app )
  •  Pulsación en el  Botón derecho => OPEN MODULE SETTINGS:
openmodules.png
  •  Nos aparecerá  otro menú  con cinco pestañas  posicionándose por defecto en Properties  donde especificamos la versión del complilador , la cual recomendamos dejar en la máxima versión( 7.1.1):
properties.PNG
  • Haremos clic sobre la tercera pestaña FLAVORS:
ejmplo
  •  Aparecen en esta pantalla   el nivel dela API minimo y  otras parametros . Pincharemos en el desplegable de MIN SDK VERSION, donde podemos escoger el nuevo API LEVEL ( clic sobre la flecha )  que deseemos:
androidversionmion
Una vez situados aquí, también  podemos  cambiar el código de la versión del APK, que es efectivamente el que tenemos seleccionado. El primer APK por defecto lleva versionCode 1, pero la siguiente versión debe llevar el 2 y así sucesivamente, de ahí a quGoogle Play de error si subimos un APK con la misma versionCode o código de versión.Lo que haremos será tan sencillo como cambiar la Version Code cada vez que generamos una nueva versión de la aplicación, es decir, un nuevo APK a publicar. Una vez hecho esto, tan solo tendremos que guardar el proyecto y volver a generar el APK.
  • GRADLE reconstruirá  automáticamente todo el proyecto ( SYNC )  al  darle al botón Aceptar
  • Este proceso podemos repetirlo cuantas veces deseemos con diferentes versiones para adaptar nuestro proyecto a las diferentes versiones de Android
 Con esta actuación ( y todas las que deseemos )   habremos configurado el fichero  build.gradle (Module:app) de forma segura   y  completamente funcional.
Anuncios

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s