Interfaz con fonera pra robot automower


Hoy todo el mundo tiene un Wi-Fi (WLAN)-router en casa conectado a Internet. Por lo tanto, parece natural para supervisar y controlar el robot Automower a través de la interfaz de radio WLAN: esto es ahora posible!
La base de hardware de la WLAN-Modul es un mini router “Fonera 2.0”, tipo 2200 o 2100. Los routers  se han distribuido por cientos de miles a través de la “red FON comunidad” hasta 2008, ver http://fr.wikipedia.org/wiki/FON . Es muy fácil de encontrar en una tienda de segunda mano (ebay …)
El router Fonera se integrará dentro del robot Automower, ya sea bajo el teclado robot como en el siguiente video o cerca de la rueda derecha. Será completamente protegido del calor lluvia, la suciedad y también. Debido a su antena WiFi externo, tiene un alcance de radio muy bueno para bajo consumo de energía: 3W 150mA a 20V es aceptable en comparación con 27W consumidos por el robot en el trabajo.
Basta con echar un vistazo al siguiente video para ver lo fácil que es configurar la interfaz en pocos minutos:

La pequeña caja redonda gris la imagen siguiente es la fuente de alimentación de la fonera que está conectado con el robot a través del conector blanco de la placa madre (esta conexión es totalmente equivalente al puerto serie externo en el botom del robot, pero el conector aquí en la placa madre tiene una mejor protección contra el polvo y la humedad):

Si lo desea, también puede poner la fonera bajo el capó verde, cerca del botón de parada, de esta manera sigue siendo accesible y también se puede ver a los pequeños leds verdes por el poder y WLAN.

Para aquellos que quieren poner la fonera en la parte delantera del robot, también es posible:

Para la parte de software, todo funciona ahora como si el robot sería un elemento de la red IP. Esto significa que el robot será accesible a través de su propia dirección IP y un puerto específico en IP que se enlaza a su interfaz de serie. Por tanto, el robot se hace accesible desde cualquier lugar! Desde un PC local en el país, desde una PDA, un teléfono inteligente conectado a Internet en el otro extremo del planeta!
Vamos a empezar con el caso más simple: un seguimiento directo del robot a través de un PC local en el país. Para utilizar PC-software que controla el robot a través de una interfaz serial real, sólo tenemos que instalar el software gratuito Puerto Perle Verdadero.
Este software emula un puerto serie del PC local. Está disponible para sistemas Windows y Linux. Este puerto serie virtual será el puerto en serie del robot exactamente como si el robot se conecta directamente al PC a través de un cable serie local. En la configuración, sólo será necesario indicar la IP robots (en este caso 192.168.1.10 en el exemple) y el IP-puerto (2001).




Tan pronto como el puerto serie virtual se establece (aquí COM5), se puede probar el enlace con el robot a través de un pequeño software que muestra la temperatura y la tensión de la batería. También es posible dar algunas órdenes al robot, por ejemplo, “ir a casa!” o “ir a trabajar”. Este es el ejemplo más simple de control del robot. Por supuesto, también puede controlar el robot en tiempo real si tienes una webcam fija en el robot, vea este video:http://www.youtube.com/watch?v=MqIHruVACj0 .

En lugar de verdadero puerto Perle, también puede utilizar el software libre . HW VSP3 En ese caso la configuración es aún más fácil, sólo tiene que indicar la dirección IP (192.168.1.200 en el ejemplo siguiente) y el puerto IP (2001):

Una tercera posibilidad libre e incluso con más funciones potentes parece ser EMULADOR VIRTUAL SERIAL PORT de Eterlogic, pero yo no lo he probado.

Más información aqui

Licencia Creative Commons
solo-electronicos por Carlos Rodriguez Navarro se encuentra bajo una Licencia Creative Commons Atribución-NoComercial-CompartirIgual 3.0 Unported.

Anuncios

Como instalar un paquete para controlar el GPIO de tu fonera


El siguiente documento pretende explicar como controlar los puertos del GPIO de la fonera en la que deberemos tener instalado previamente OpenWRT.

Para ello deberemos descargar he instalar el paquete necesario segun nuestra version de kernel

-Para kernel 2.6.19.1 (OpenWRT Kamikaze 7.06) : http://fghhgh.150m.com/kmod-gpio_2.6.19.1-atheros-1_mips.ipk
-Para kernel 2.6.21.5 (OpenWRT Kamikaze 7.09) :http://fon.testbox.dk/packages/2.6.21.5/kmod-gpio_2.6.21.5-atheros-1_mips.ipk

Tambien podemos hacerlo directamente desde la fonera si esta tiene conexion a internet, utlizando “ipkg” para Kamikaze 7.09
ipkg install http://fon.testbox.dk/packages/2.6.21.5/kmod-gpio_2.6.21.5-atheros-1_mips.ipk  (*)

 
Una vez instalado el paquete ya solo tenemos que cargar el modulo para ello escribiremos:
insmod proc_gpio.ko

 
Una vez hecho esto y para poder encender  al  puerto 2 del GPIO( normalmente conectada a WLAN)  deberemos escribir primero
echo 1 > /proc/gpio/2_dir

 
Luego ya para encender o apagar escribiremos:
echo 1 > /proc/gpio/2_out #Para encender
echo 0 > /proc/gpio/2_out #Para apagar.

El control sobre los bits del GPIO y en particular el de dicha luz, nso permite utilizarla para indicar los procesos que queramos, como por ejemplo
* Indicar si la fonera tiene conexion a internet
* Indicar cuando a terminado de iniciarse la fonera
* Indicar si nos a detectado una tarjeta SD en la fonera [[Instalar tarjeta SD en la Fonera]]
* etc

Por ultimo, para que cargue esto “insmod proc_gpio.ko” al encender la fonera editamos  el /etc/init.d/custom-user-startup

vi /etc/init.d/custom-user-startup
pulsamos i
insertamos uanlinea  con insmod proc_gpio.ko  por ahi..debajo de lo que viene con # (todo lo que lleva # hace que no se ejecute, es como si fueran las notas que se ponen en HTML)

Pulsamos ESCAPE :wq! ENTER

y ya está

(*) NOTA IMPORTANTE: Si no consigues descargarte el fichero kmod-gpio_2.6.21.5-atheros-1_mips.ipk del  sitio  http://fon.testbox.dk/packages/2.6.21.5/ recomiendo bajarse el fichero mmc-driver.tar.gz (**)  para esta distribucion ( por ejemplo de  AQUI,descomprimirlo en tu PC  con el winrar  y despues copiar de ahi el fichero  kmod-gpio_2.6.21.5-atheros-1_mips.ipk  con el programa winscp al directorio temp de la fonera  y ya solo tendremos que ejecutar los siguientes comandos:

[email protected]:~# ipkg install kmod-gpio_2.6.21.5-atheros-1_mips.ipk
Installing kmod-gpio (2.6.21.5-atheros-1) to root…
Configuring kmod-gpio
Done.
[email protected]:~# insmod proc_gpio.ko

[email protected]:/# cd proc
[email protected]:/proc# cd gpio
[email protected]:/proc/gpio# ls

0_in    12_dir  14_out  17_in   1_dir   21_out  4_in    7_dir   9_out
0_out   12_in   15_dir  17_out  1_in    2_dir   4_out   7_in    info
10_dir  12_out  15_in   18_dir  1_out   2_in    5_dir   7_out
10_in   13_dir  15_out  18_in   20_dir  2_out   5_in    8_dir
10_out  13_in   16_dir  18_out  20_in   3_dir   5_out   8_in
11_dir  13_out  16_in   19_dir  20_out  3_in    6_dir   8_out
11_in   14_dir  16_out  19_in   21_dir  3_out   6_in    9_dir
[email protected]:/proc/gpio# echo 1 > /proc/gpio/2_dir
[email protected]:/proc/gpio# echo 1 >/proc/gpio/2_out  —> con esto se encendera la luz WLAN de la fonera

(**)  el paquete mmc-driver.tar.gz se utiliza para dar soporte MMC a la fonera  incluyenod los siguientes repositorios:

kmod-gpio_2.6.21.5-atheros-1_mips.ipk——>este es el que nos interesa para el control del GPIO
kmod-nls-base_2.6.21.5-atheros-1_mips.ipk
kmod-nls-cp437_2.6.21.5-atheros-1_mips.ipk
kmod-nls-iso8859-1_2.6.21.5-atheros-1_mips.ipk
kmod-fs-vfat_2.6.21.5-atheros-1_mips.ipk
kmod-fs-ext2_2.6.21.5-atheros-1_mips.ipk
mmc-driver-fonera_0.1_mips.ipk

Como instalar un paquete para controlar el GPIO de tu fonera


El siguiente documento pretende explicar como controlar los puertos del GPIO de la fonera en la que deberemos tener instalado previamente OpenWRT.

Para ello deberemos descargar he instalar el paquete necesario segun nuestra version de kernel

-Para kernel 2.6.19.1 (OpenWRT Kamikaze 7.06) : http://fghhgh.150m.com/kmod-gpio_2.6.19.1-atheros-1_mips.ipk
-Para kernel 2.6.21.5 (OpenWRT Kamikaze 7.09) :http://fon.testbox.dk/packages/2.6.21.5/kmod-gpio_2.6.21.5-atheros-1_mips.ipk

Tambien podemos hacerlo directamente desde la fonera si esta tiene conexion a internet, utlizando “ipkg” para Kamikaze 7.09
ipkg install http://fon.testbox.dk/packages/2.6.21.5/kmod-gpio_2.6.21.5-atheros-1_mips.ipk  (*)

 
Una vez instalado el paquete ya solo tenemos que cargar el modulo para ello escribiremos:
insmod proc_gpio.ko

 
Una vez hecho esto y para poder encender  al  puerto 2 del GPIO( normalmente conectada a WLAN)  deberemos escribir primero
echo 1 > /proc/gpio/2_dir

 
Luego ya para encender o apagar escribiremos:
echo 1 > /proc/gpio/2_out #Para encender
echo 0 > /proc/gpio/2_out #Para apagar.

El control sobre los bits del GPIO y en particular el de dicha luz, nso permite utilizarla para indicar los procesos que queramos, como por ejemplo
* Indicar si la fonera tiene conexion a internet
* Indicar cuando a terminado de iniciarse la fonera
* Indicar si nos a detectado una tarjeta SD en la fonera [[Instalar tarjeta SD en la Fonera]]
* etc

Por ultimo, para que cargue esto “insmod proc_gpio.ko” al encender la fonera editamos  el /etc/init.d/custom-user-startup

vi /etc/init.d/custom-user-startup
pulsamos i
insertamos uanlinea  con insmod proc_gpio.ko  por ahi..debajo de lo que viene con # (todo lo que lleva # hace que no se ejecute, es como si fueran las notas que se ponen en HTML)

Pulsamos ESCAPE :wq! ENTER

y ya está

(*) NOTA IMPORTANTE: Si no consigues descargarte el fichero kmod-gpio_2.6.21.5-atheros-1_mips.ipk del  sitio  http://fon.testbox.dk/packages/2.6.21.5/ recomiendo bajarse el fichero mmc-driver.tar.gz (**)  para esta distribucion ( por ejemplo de  AQUI,descomprimirlo en tu PC  con el winrar  y despues copiar de ahi el fichero  kmod-gpio_2.6.21.5-atheros-1_mips.ipk  con el programa winscp al directorio temp de la fonera  y ya solo tendremos que ejecutar los siguientes comandos:

[email protected]:~# ipkg install kmod-gpio_2.6.21.5-atheros-1_mips.ipk
Installing kmod-gpio (2.6.21.5-atheros-1) to root…
Configuring kmod-gpio
Done.
[email protected]:~# insmod proc_gpio.ko

[email protected]:/# cd proc
[email protected]:/proc# cd gpio
[email protected]Wrt:/proc/gpio# ls
0_dir   11_out  14_in   17_dir  19_out  21_in   4_dir   6_out   9_in
0_in    12_dir  14_out  17_in   1_dir   21_out  4_in    7_dir   9_out
0_out   12_in   15_dir  17_out  1_in    2_dir   4_out   7_in    info
10_dir  12_out  15_in   18_dir  1_out   2_in    5_dir   7_out
10_in   13_dir  15_out  18_in   20_dir  2_out   5_in    8_dir
10_out  13_in   16_dir  18_out  20_in   3_dir   5_out   8_in
11_dir  13_out  16_in   19_dir  20_out  3_in    6_dir   8_out
11_in   14_dir  16_out  19_in   21_dir  3_out   6_in    9_dir
[email protected]:/proc/gpio# echo 1 > /proc/gpio/2_dir
[email protected]:/proc/gpio# echo 1 >/proc/gpio/2_out  —> con esto se encendera la luz WLAN de la fonera

(**)  el paquete mmc-driver.tar.gz se utiliza para dar soporte MMC a la fonera  incluyenod los siguientes repositorios:

kmod-gpio_2.6.21.5-atheros-1_mips.ipk——>este es el que nos interesa para el control del GPIO
kmod-nls-base_2.6.21.5-atheros-1_mips.ipk
kmod-nls-cp437_2.6.21.5-atheros-1_mips.ipk
kmod-nls-iso8859-1_2.6.21.5-atheros-1_mips.ipk
kmod-fs-vfat_2.6.21.5-atheros-1_mips.ipk
kmod-fs-ext2_2.6.21.5-atheros-1_mips.ipk
mmc-driver-fonera_0.1_mips.ipk

Router con open-wrt como repetidor wifi


En ocasiones, nos podria interesar que nuestro router con   open-wrt   nos permitiera conectarnos a una red wifi para retransmitir esta señal  y de esta forma mejorar el alcance del router principal.

Para  configurar nuestro router con open-wrt   seguiremos estos pasos:

1º Configuraremos el  fichero  /etc/config/network
config interface loopback
option ifname   lo
option proto    static
option ipaddr   127.0.0.1
option netmask  255.0.0.0

config interface lan
option ifname   eth0
option type     bridge
option proto    static
option ipaddr   192.168.2.1   #es importante cambiar este valor para que nos podamos conectar al router anfitrion  cuya io sera 192.168.1.1
option netmask  255.255.255.0
option gateway  ‘192.168.1.1’

config interface wan
option ifname ath0
option proto    ‘dhcp’
option dns      ‘80.58.61.250’
option ipaddr   ”
option netmask  ”
option gateway  ‘192.168.1.1’

2º Configuraremos el fichero /etc/config/wireless

config wifi-device  wifi0
option type     atheros
option channel  5
option disabled ‘0’
option mode     ’11bg’
option diversity        ‘0’
option txantenna        ‘0’
option rxantenna        ‘0’
config wifi-iface
option device   wifi0
option network  lan
option mode     ap
option ssid     OpenWrt    #nueva red  a la que nos conectaremos
option encryption wep
option key      ‘1’
option hidden   ‘0’
option isolate  ‘0’
option txpower  ‘0’
option bgscan   ‘0’
option wds      ‘0’
option key1     ‘FFFFFFFFFFFFFFFFFFFFFFFFFF’   #clave wep en formato exadecimal

config wifi-iface
option device wifi0
option network wan
option mode sta
option ssid WLAN_7F  # red a repetir  que repetiremos
option encription wep
option key      ‘1’
option encryption       ‘wep’
option hidden   ‘0’
option isolate  ‘0’
option txpower  ‘0’
option bgscan   ‘0’
option wds      ‘0’
option key1     ‘FFFFFFFFFFFFFFFFFFFFFFFFFF’ #clave wep de la red a repetir

3 Revisamos la conexion en Luci en http:\\192.168.2.1

Primero miramos network

4-Y  ahora revisamos el apartado de wireless tanto generales como para la LAN y la WAN

Router con open-wrt como repetidor wifi


En ocasiones, nos podria interesar que nuestro router con   open-wrt   nos permitiera conectarnos a una red wifi para retransmitir esta señal  y de esta forma mejorar el alcance del router principal.

Para  configurar nuestro router con open-wrt   seguiremos estos pasos:

1º Configuraremos el  fichero  /etc/config/network
config interface loopback
        option ifname   lo
        option proto    static
        option ipaddr   127.0.0.1
        option netmask  255.0.0.0

config interface lan
        option ifname   eth0
        option type     bridge
        option proto    static
        option ipaddr   192.168.2.1   #es importante cambiar este valor para que nos podamos conectar al router anfitrion  cuya io sera 192.168.1.1
        option netmask  255.255.255.0
        option gateway  ‘192.168.1.1’

config interface wan
       option ifname ath0
        option proto    ‘dhcp’
        option dns      ‘80.58.61.250’
        option ipaddr   ”
        option netmask  ”
        option gateway  ‘192.168.1.1’

2º Configuraremos el fichero /etc/config/wireless

config wifi-device  wifi0
        option type     atheros
        option channel  5
        option disabled ‘0’
        option mode     ’11bg’
        option diversity        ‘0’
        option txantenna        ‘0’
        option rxantenna        ‘0’
config wifi-iface
        option device   wifi0
        option network  lan
        option mode     ap
        option ssid     OpenWrt    #nueva red  a la que nos conectaremos
        option encryption wep
        option key      ‘1’
        option hidden   ‘0’
        option isolate  ‘0’
        option txpower  ‘0’
        option bgscan   ‘0’
        option wds      ‘0’
        option key1     ‘FFFFFFFFFFFFFFFFFFFFFFFFFF’   #clave wep en formato exadecimal

config wifi-iface
        option device wifi0
        option network wan
        option mode sta
        option ssid WLAN_7F  # red a repetir  que repetiremos
        option encription wep
        option key      ‘1’
        option encryption       ‘wep’
        option hidden   ‘0’
        option isolate  ‘0’
        option txpower  ‘0’
        option bgscan   ‘0’
        option wds      ‘0’
        option key1     ‘FFFFFFFFFFFFFFFFFFFFFFFFFF’ #clave wep de la red a repetir

3 Revisamos la conexion en Luci en http:\\192.168.2.1

Primero miramos network

4-Y  ahora revisamos el apartado de wireless tanto generales como para la LAN y la WAN