Instalación de OpenWrt en las Fonera FON 2201 CON FIRMWARE Version 8.09SOBRE WINDOWS VISTA


Todas las Foneras vienen con el gestor de arranque RedBoot, que además se encarga del particionado de la flash y desde donde se puede flashear la memoria interna. El acceso al gestor se puede realizar o por puerto serie, o por red, siendo este último sistema el más como y es el que se va a comentar.
En los primeros modelos el acceso por red estaba capado por lo que era necesario acceder por puerto serie o utilizar algún fallo de seguridad para poder habilitarlo. Pero desde hace ya bastante tiempo todas vienen con el acceso por red totalmente funcional

PASOS PREVIOS
1-DESCARGAR FICHEROS ULTIMA DISTRIBUCION:
http://downloads.openwrt.org/kamikaze/8.09.1/

2-ARRANCAR tfpt32 SIRVIENDO LOS DOS FICHEROS

3-Arrancar el putty con 192.68.1.9:9000 sesion de telnet en los dos primeros segundos con un cable cruzado conectado al Puerto LAN

Flasheo openwrt 8.01
Una vez que se ha accedido al RedBoot pasamos a flashear.
Primero configuramos el acceso al servidor tftp (la IP tiene que cambiarse a la del PC):

RedBoot> ip_address -h 192.168.1.254
IP: 192.168.1.1/255.255.255.0, Gateway: 0.0.0.0
Default server: 192.168.1.254

y comprobamos que hay comunicación

RedBoot> ping -h 192.168.1.254
Network PING – from 192.168.1.1 to 192.168.1.254
PING – received 10 of 10 expected

Reiniciamos las particiones de la flash (10s):

RedBoot> fis init
About to initialize [format] FLASH image system – continue (y/n)? y
*** Initialize FLASH Image System
… Erase from 0xa87e0000-0xa87f0000: .
… Program from 0x80ff0000-0x81000000 at 0xa87e0000: .

Y cargamos el kernel desde el PC a memoria usando TFTP (según la version de OpenWrt version 8.09):

RedBoot> load -r -b %{FREEMEMLO} openwrt-atheros-vmlinux.lzma
Using default protocol (TFTP)
Raw file loaded 0x80040400-0x801003ff, assumed entry at 0x80040400

Y lo flasheamos (2m-5m):

RedBoot> fis create -e 0x80041000 -r 0x80041000 vmlinux.bin.l7
… Erase from 0xa8030000-0xa80f0000: …………
… Program from 0x80040400-0x80100400 at 0xa8030000: …………
… Erase from 0xa87e0000-0xa87f0000: .
… Program from 0x80ff0000-0x81000000 at 0xa87e0000: .

Cargamos la imagen del sistema de archivos (nombre dependiente de la versión de OpenWrt):

RedBoot> load -r -b %{FREEMEMLO} openwrt-atheros-root.squashfs
Using default protocol (TFTP)
Raw file loaded 0x80040400-0x801e03ff, assumed entry at 0x80040400

Pero antes de flashearla necesitamos saber el espacio libre que queda en la flash:

RedBoot> fis free
0xA80F0000 .. 0xA87E0000

Y ahora 0xA87E0000-0xA80F0000 .= 0x6f0000 lo flasheamos, con el tamaño de la memoria libre obtenido anteriormente (4m-11m):

RedBoot> fis create -l 0x6f0000 rootfs
… Erase from 0xa80f0000-0xa87e0000: …………………………………………………………………………………………………
… Program from 0x80040400-0x801e0400 at 0xa80f0000: ……………………..
… Erase from 0xa87e0000-0xa87f0000: .
… Program from 0x80ff0000-0x81000000 at 0xa87e0000: .

Por último en la Fonera+ y 2.0 han cambiando el script de arranque, por lo que habrá que modificarlo para que el sistema arranque bien.
Lo visualizamos asi:

RedBoot> fconfig -l
Run script at boot: true
Boot script:
.. fis load loader
.. go

Boot script timeout (1000ms resolution): 210
Use BOOTP for network configuration: false
Gateway IP address: 0.0.0.0
Local IP address: 192.168.1.1
Local IP address mask: 255.255.255.0
Default server IP address: 192.168.1.254
Console baud rate: 9600
GDB connection port: 9000
Force console for special debug messages: false
Network debug at boot time: false

Y ahora lo modificamos:

RedBoot> fconfig boot_script_data
boot_script_data:
.. fis load loader
.. go
Enter script, terminate with empty line
>> fis load -l vmlinux.bin.l7
>> exec
>>
Update RedBoot non-volatile configuration – continue (y/n)? y
… Erase from 0xa87e0000-0xa87f0000: .
… Program from 0x80ff0000-0x81000000 at 0xa87e0000: .

Y con esto ya está listo, solo queda resetear y cruzar los dedos:

.
RedBoot> reset

Acceso a OpenWrt
El accesso se realiza a través de la IP 192.168.1.1, primeramente por telnet. Hay que esperara un poco y en las Foneras con varios RJ-45 hay que conectar la red al puerto COMPUTER:

telnet a 192.168..1.1 puerto 23

Tras lo que se le pone un password:
[email protected]:/# passwd
Changing password for root
New password:
Retype password:
Password for root changed by root
[email protected]:/# exit
y ya se puede entrar por ssh (después de esperar un rato, mientras crea las identidades.ede decir :

-cerramos el putty con el telnet al 192.168.1.1 :9000
-abrimos el putty con ssh 192.168.1.1:22

y ya se puede entrar por ssh (después de esperar un rato, mientras crea las identidades):

192.168.1.1puerto 22 modo s ssh

login as: root
[email protected]’s password:

BusyBox v1.11.2 (2009-05-28 20:21:24 UTC) built-in shell (ash)
Enter ‘help’ for a list of built-in commands.

_______ ________ __
| |.—–.—–.—–.| | | |.—-.| |_
| – || _ | -__| || | | || _|| _|
|_______|| __|_____|__|__||________||__| |____|
|__| W I R E L E S S F R E E D O M
KAMIKAZE (8.09.1, r16278) —————————-
* 10 oz Vodka Shake well with ice and strain
* 10 oz Triple sec mixture into 10 shot glasses.
* 10 oz lime juice Salute!
—————————————————
[email protected]:~# cat /etc/config/wireless
config wifi-device wifi0
option type atheros
option channel auto

# REMOVE THIS LINE TO ENABLE WIFI:
option disabled 1

config wifi-iface
option device wifi0
option network lan
option mode ap
option ssid OpenWrt
option encryption none
[email protected]:~#

INTRODCIREMOS LSO DATOS DE NUESTRA WIFI

[email protected]:~# vi /etc/config/wireless
config wifi-device wifi0
option type atheros
option channel auto

# REMOVE THIS LINE TO ENABLE WIFI:
# option disabled 1

config wifi-iface
option device wifi0
# option network lan
option mode sta
option ssid WLAN_DBb
option encryption wep
option key 4341524c4f

EDITAREMOS /etc/config/network

[email protected]:~# vi /etc/config/network

config ‘interface’ ‘loopback’
option ‘ifname’ ‘lo’
option ‘proto’ ‘static’
option ‘ipaddr’ ‘127.0.0.1’
option ‘netmask’ ‘255.0.0.0’

config ‘interface’ ‘lan’
option ‘type’ ‘bridge’
option ‘proto’ ‘static’
option ‘ipaddr’ ‘192.168.1.1’
option ‘netmask’ ‘255.255.255.0’
option ‘ifname’ ‘eth0.0’

config ‘interface’ ‘wan’
option ‘ifname’ ‘eth0.1’
option ‘proto’ ‘dhcp’

NOS QIEDARA ASI

[email protected]:~# vi /etc/config/network

config ‘interface’ ‘loopback’
option ‘ifname’ ‘lo’
option ‘proto’ ‘static’
option ‘ipaddr’ ‘127.0.0.1’
option ‘netmask’ ‘255.0.0.0’

config ‘interface’ ‘lan’
option ‘type’ ‘bridge’
option ‘proto’ ‘static’
option ‘ipaddr’ ‘192.168.1.100’
option ‘netmask’ ‘255.255.255.0’
option ‘ifname’ ‘eth0.0’

config ‘interface’ ‘wan’
option ‘ifname’ ‘eth0.1’
option ‘proto’ ‘dhcp’

HECHOS ESTOS CAMBIOS

-REINICIAR EL ROUTER CONRESET

-APAGAR Y ENCENDER EL RUTER

-ESPERAR 2-.3 MINUTOS(tarda bastante!!) HASTA QEU SE APAGUE ELLED DE POWER Y PARPADEDEE EL LED DE WIRELESS

Anuncios

3 comentarios el “Instalación de OpenWrt en las Fonera FON 2201 CON FIRMWARE Version 8.09SOBRE WINDOWS VISTA

  1. taikson dice:

    Ya me estaba volviendo loco flasheando la FON2201. Hacía todos los pasos de la wiki de OpenWRT y no arrancaba. Gracias por postear los pasos adicionales para que enganchara el script de arranque.

    Muy buen post!.

    Me gusta

  2. Chechu dice:

    Buenas tardes.

    Una pregunta. ¿La configuración de red que has puesto es para modo cliente? ¿Conectas algo al puerto ethernet de la fonera? ¿Se asigna ip automaticamente o hay que ponerla estática (en el dispositivo conectado)?

    Muchas gracias y un saludo,
    Chechu

    Me gusta

  3. Toda la configuracion la puedes manejar a atraves del interfaz grafico del open-wrt.
    Lo mas complicado es que haga de bridge ,pero no te preocupes, en este blog he puesto la configuracion pantalla a pantalla de esta configuracion ( se conecta a una wirleess y restransmite esta señal tanto por wifi como por cable).

    Me gusta

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s